*** 検定・単回帰分析 ***

１．概要

1.1 検定

我々がプロセスを評価する場合，その殆どは精度と正確さへの関心と

なり，その具体的な行為は現状と目標に違いがあるのかの問い掛けに

なります。この問い掛けに客観的に答えてくれる統計ツールが“仮説

検定”です。

目標対象には二つの場合があり，その一つは上図に示すような規格値

などの具体的な数値，もう一つは比較対象である別の母集団（ベンチ

マーク）です。サンプルデータから，現状の母集団パラメータを具体

的な数値と比較（違いがあるかをテスト）する，あるいは別な母集団

パラメータと比較する行為を，統計的仮説検定といいます。

1.2 単回帰分析

圧力と流量（電気では電圧と電流）などの関係では，一方の連続的な

変化に対して，もう一方が変化量に応じて変化することが法則として

知られています。この場合は一方の値が決まれば実験を行わなくても，

もう一方の値を知ることができます。しかし二つの変量の関係が未知

の場合は，実験を実施しないと正確な値を推定することはできません。

単回帰分析は，二つの変量間の法則を見つけるための手法で，その関

係を一次式y=a+bxとして分析します。この一次式のパラメータを推定

する為を，単回帰分析といいます。

２．適用・用途

2.1 仮説検定

調査対象の母集団が規格値（目標値，規格幅）を満足しているか，調

査対象と別の母集団との間に差があるかを，標本データに基づいて調

べます。

1)1標本データの母平均に関する検定（分散既知）

サンプルデータから，母平均が特定の値（目標値など）であるかをテ

ストします。

H0：μ＝目標値

H1：μ≠目標値

2)1標本データの母平均に関する検定（分散未知）

1)と同様であるが，一般的には母分散が予め分かっていることは少な

く，分散未知で検定することが多くなります。

3)2標本データの母平均の差に関する検定（分散既知）

2組（一方は現状でもう一方はベンチマーク）のサンプルデータから，

2組の母平均に差があるかをテストします。

H0：μ1＝μ2

H1：μ1≠μ2

4)2標本データの母平均の差に関する検定（分散未知：等分散）

3)と同様であるが，母分散が未知（等分散）になります。

5)2標本データの母平均の差に関する検定（分散未知：不等分散）

3)と同様であるが，母分散が未知（不等分散）になります。

6)1標本データの母分散に関する検定

サンプルデータから，母分散が特定の値（例：規格幅の1/8など）

であるかをテストします。

H0：σ2＝σ02 例：σ0=（規格幅／8）

H1：σ2≠σ02

7)2標本データの母分散に関する検定

2組（一方は現状でもう一方はベンチマーク）のサンプルデータから，

2組の母分散に差があるかをテストします。

H0：σ12＝σ22

H1：σ12≠σ22

8)対の2標本データの母平均に関する検定

2組の対になっているサンプルデータから，母平均の差を絶対値では

なく個々のデータの差（d1=x1-x2）から，検定します。

定します。

2.2 単回帰分析

二つの関連する変量（x,y）について，xとyの関係の度合いはどの程

度の強さか，xからyを予測する際にどの程度正確に予測可能かを調

べます。前者を相関分析，後者を回帰分析といいます。

３．分析手順

3.1 仮説検定

1) STEP1（データファイルの作成）

メインアイテムから[データファイルの作成]を選択，サブアイテムか

ら[EXCEL data format]を選択し，[一般解析用]data formatで作成し

ます。縦(行)方向はデータ数，横(列)方向は水準(標本)数の，基本的

な入力方法で入力します。

2) STEP2（ファイルの読込み）

メインアイテムから[統計解析（連続データ）]を選択，サブアイテム

から[検定（母平均・母分散）・単回帰分析]を選択し[GO]をクリック

します。[メニュー]操作よりデータファイルを読み込むと，データリ

ストビュー各列に個別データが表示されます。データ表示は個別デー

タと基本統計量を，切り替えることができます。

3) STEP3（検定条件の設定）

データ水準列（調査対象となる母集団のサンプルデータ）を，データ

リストビューの[column]ボタンにより選択（[c-selected]欄に#1が表

示）します。検定（解析）アイテムと検定方向を選択します。

4) STEP4（検定条件の入力）

検定条件リストビューの[Setting]をクリックし，設定ウィンドウの

項目に従って所要の値を入力し，[OK]をクリックします。

5) STEP5（結果の出力）

[解析]ボタンをクリックすると，設定条件に応じた検定結果が出力さ

れます。

3.2 回帰分析

1) STEP1（データファイルの作成）

メインアイテムから[データファイルの作成]を選択，サブアイテムか

ら[EXCEL data format]を選択し，[一般解析用]data formatで作成し

ます。縦(行)方向はデータ数，横(列)方向は水準(標本)数の，基本的

な入力方法で入力しますが，（x,y）は以下のようになります。

第一水準：X 第二水準：Y

2) STEP2（ファイルの読込み）

メインアイテムから[統計解析（連続データ）]を選択，サブアイテム

から[検定（母平均・母分散）・単回帰分析]を選択し[GO]をクリック

します。[メニュー]操作よりデータファイルを読み込むと，データリ

ストビュー各列に個別データが表示されます。データ表示は個別デー

タと基本統計量を，切り替えることができます。

3) STEP3（検定条件の設定）

データ水準列（関係のある2変量）を，データリストビューの[column]

ボタンにより選択（[c-selected]欄に#1，#2が表示）します。検定

（解析）アイテムと検定方向を選択します。

4) STEP4（検定条件の設定）

検定条件リストビューの[Setting]をクリックし，設定ウィンドウの

項目に従って所要の値を入力し，[OK]をクリックします。

5) STEP5（結果の出力）

[解析]ボタンをクリックすると，設定条件に応じた検定結果が出力さ

れます。散布図はメニュー操作により出力されます。

                 （散布図）